Troubleshooting API

Here are some common reasons why your API calls to FLG might fail.

Error 'No post data was provided'

This means our server didn't see the XML request it was expecting.  This may be because:

  • You made a HTTP GET request instead of POST (we expect the XML as the body/payload of the POST request).
  • The POST didn't have the correct Content-Type header - use Content-Type: application/xml so our server knows you're sending XML.
  • Sometimes whitespace before the XML content causes problems, check for that too.

Error 'The input could not be parsed'

If you get this error, it means we received something, but it didn't look like valid XML.  This error is almost always because:

  • You didn't send XML.  That's the only data format the API accepts.
  • One or more XML tags weren't closed properly or don't match up.  Look for <tag><tag> or <tag></tagg> (should be <tag></tag> of course).
  • The special characters in XML weren't encoded.  You need to use predefined entities to describe ", &, ', < and >.  Learn more about XML's predefined entities.

Further Help

In order for us to help you to troubleshoot API requests, please send us a trace of the request and response.  Runscope is a great tool for doing this.  It works by acting as a proxy between your server and the API and giving you full transparency into what the request contained and what the server sent back.

It's really difficult for us to help out without a trace, so please get hold of this before you get in touch.  As soon as you have it, we're here and ready to help!

Feedback and Knowledge Base